最近,PCL群真的有太多新手了,他们总是在问如何装Mod,光影,地图等问题
所以,今天我就写篇文章来专门讲这个问题吧

前言:(⚠必看)

  1. 进群(指PCL群)要看群公告📢,特别是置顶公告,确定群公告无相关问题后再来询问
  2. 遇到问题先查看是不是自己没联网📶、游戏没解压等
  3. 简单的问题自己百度/搜狗/必应/谷歌/b站搜索过后,没有找到相关的信息或者根据教程处理完后没解决再问(不是自己操作电脑真的很难用文字去描述,别为难我们,你自己去看视频教程可能更快)
  4. 具体问题具体分析,不要一上来就问MC怎么玩,PCL怎么用等(范围太大很难解决问题)
  5. 我们群的每个人都不一定有时间🕓帮你解答问题,这个群没有客服,所以回答你的问题也不是我们的义务,请不要反复@或者刷屏💢,能否解决问题随缘
  6. 推荐一个b站up主,里面包含了几乎所有你可能出现的问题

    游戏安装
    mod与材质
    皮肤地图整合包
    mod的查找
    整合包的安装
    常用mod推荐

基本概念:

1.游戏目录:指游戏存放的目录(一般文件夹名叫.minecraft)

查看方法:

  • PCL1的设置-Minecraft文件夹
  • PCL2版本选择左侧的小字部分可以看到(也可以右键打开)
  • 自行在资源管理器里打开

目录结构:(只说基本的,其他没啥用不用管)

  • assets,libraries支持库(最好别动)
  • versions版本文件夹(如果开启版本隔离,以下文件都会在该文件夹里而不是游戏目录下)
    • saves地图(可以导入导出)
    • logs,crash-reports日志(在游戏崩溃时可以查看)
    • resourcepacks材质包
    • shaderpacks光影包
    • backups地图备份
    • mods模组文件夹
    • options.txt,optionsof.txt,optionsshaders.txt分别为原版、optifine版和光影相关的设置
    • servers.dat服务器列表

2.Forge

安装mod的必须安装的接口

3.Farbic

跟forge差不多,只是支持的mod有别

4.optifine

安装光影和调整游戏视频设置的接口

常见问题

如何装mod

  1. 下载并安装相应版本的forge(PCL1不支持部分版本,最好去官网下载)
  2. 试着启动一次forge版本,试下是否安装成功
  3. 下载想要的mod
    下面是两个热门的下载站
    https://www.mcbbs.net/portal.php
    https://minecraft.curseforge.com/
  4. 把mod(通常以.jar结尾)复制到 游戏目录(.minecraft)/mods 文件夹(如开启版本隔离复制到 游戏目录(.minecraft)/versions/对应forge版本/mods 文件夹)

如何开光影

⚠1.15.2仅pre10或以上的optifine版本支持光影

  1. 下载并安装相应版本的optifine(PCL1不支持部分版本,最好去官网https://optifine.net/)
  2. 启动带optifine的游戏
  3. 下载好的光影复制到 游戏目录(.minecraft)/shaderpacks 文件夹(如开启版本隔离复制到 游戏目录(.minecraft)/versions/对应optifine版本/shaderpacks文件夹)
  4. 游戏内点击 设置-视频设置-光影 即可查看和使用光影

如何在forge中开光影

⚠1.15.2暂不支持此功能(截止到2020.4.1)

  1. 下载对应版本的optifine(PCL2可以点击右侧另存为)
  2. 把optifine(通常以.jar结尾)复制到游戏目录/mods文件夹(如开启版本隔离复制到游戏目录(.minecraft)/versions/对应forge版本/mods 文件夹)
  3. 遵循“如何开光影”的3、4步

崩溃问题

⚠因为MC崩溃并不是PCL的问题,而且MC崩溃问题千千万,错综复杂,因此我们说的话不一定有用

❔提问要求

  1. 如果崩溃前有对客户端经行过修改,并且修改前能正常启动,建议还原文件(包括但不限于删除新加的mod,删除或还原options.txtoptionsof.txt等)
  2. 上传崩溃相关的文件(包括但不限于游戏的crash-report、log与PCL的log)
  3. 请上报自己的电脑软件和硬件的配置(如系统版本,显卡,内存,Java版本等)
  4. 可以说出其他有用的信息(如装了什么Mod等)

几种可能的情况✔:

  1. 显卡不支持(inter HD-HD3000核显,通常对应1-3代inter CPU)
    现象:crash-report中出现“The driver don’t support openGL”和其他类似的语句
    建议:这种情况需要额外补丁,请私聊Hao_Tian或百度寻找相关软件

  2. Mod导致的冲突崩溃
    现象:crash-report中出现“Contact their authors BEFORE contacting forge”的语句
    建议:根据crash-report内容先删除一部分或全部mod以检查mod是否冲突

  3. 使用32位Java并且内存溢出
    现象:启动器java设置中出现“Program Files(x86)”
    建议:换成64位java或者把内存调到1024M以下。64位java下载链接:https://www.java.com/en/download/manual.jsp(简单的英文看得懂吧?)

  4. Java安装出错
    现象:点击启动时弹窗出现“Error: Could not create the java virtual machine Error: A fatal exception has occurred. Program will exit.”语句
    建议:重装Java,如果使用绿色版Java移动到纯英文目录可大概率避免这种问题